您的位置:首页 > 其它

HDU-1003 Max Sum-动态规划-难度2

2014-03-20 10:16 411 查看
Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 129864    Accepted Submission(s): 30100

Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.

 

Sample Input

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

 

Sample Output

Case 1:

14 1 4

Case 2:
7 1 6

代码:

/*HDU 1003 Max Sum */
/*
*其实就是求最大子数组之和,不过需要保存起始点和结束点
*/
#include <cstdio>
#include <iostream>
#include <climits>
using namespace std;

const int  MAXN = 100002;
int dp[MAXN], first[MAXN];//first[i]保存dp[i]的起始点的位置,结束点的位置是他自己i

int main()
{
#ifdef _LOCAL
freopen("F://input.txt", "r", stdin);
#endif
int T, n;
cin >> T;
for(int j = 1; j <= T; j++)
{
cin >> n;
int temp, position = 0;
dp[0] = INT_MIN; //初始化边界条件,有负数的最小值不能是0或-1
for(int i = 1; i <= n; i++)
{
cin >> temp;
if(dp[i - 1] >= 0)
{
dp[i] = dp[i - 1] + temp;
first[i] = first[i - 1];
}
else
{
dp[i] = temp;
first[i] = i;
}
dp[i] = dp[i - 1] > 0 ? dp[i - 1] + temp : temp;
if(dp[i] > dp[position]) position = i;
}
if(j > 1) cout << endl;
cout << "Case " << j << ":" << endl << dp[position] <<  " "
<< first[position] << " " << position << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: