您的位置:首页 > 其它

HDU - 1175 连连看

2014-03-19 20:47 288 查看
题意:

Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。

玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。



Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。

注意:询问之间无先后关系,都是针对当前状态的!



Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。



Sample Input

3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0




Sample Output

YES
NO
NO
NO
NO
YES


思路:带着方向的DFS,回溯找答案

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 1010;

struct point{
	int x,y;
	bool operator == (point a){
		return x == a.x && y == a.y;
	}
}s,e;
int map[MAXN][MAXN],n,m,flag;
int vis[MAXN][MAXN];
int dx[4] = {-1,0,1,0};
int dy[4] = {0,1,0,-1};

int dfs(point x,int dir,int num){
	if (flag)
		return 1;
	if (num > 2)
		return 0;
	if (num == 2){
		if ((dir == 0 && x.y != e.y) || (dir == 1 && x.x != e.x) || 
				(dir == 2 && x.y != e.y) || (dir == 3 && x.x != e.x))
			return 0;
	}
	if (x == e){
		flag = true;
		return 1;
	}
	if (x.x < 1 || x.y < 1 || x.x > n || x.y > m || map[x.x][x.y] != 0 || vis[x.x][x.y])
		return 0;
	vis[x.x][x.y] = 1;
	for (int i = 0; i < 4; i++){
		point tmp;
		tmp.x = x.x + dx[i];
		tmp.y = x.y + dy[i];
		if (dir == i)
			dfs(tmp,i,num);
		else dfs(tmp,i,num+1);
	}
	vis[x.x][x.y] = 0;
}

int main(){
	int k;
	while (scanf("%d%d",&n,&m) != EOF && n+m){
		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= m; j++)
				scanf("%d",&map[i][j]);
		scanf("%d",&k);
		while (k--){
			scanf("%d%d%d%d",&s.x,&s.y,&e.x,&e.y);
			if (s == e){
				printf("NO\n");
				continue;
			}
			if (map[s.x][s.y] != map[e.x][e.y]){
				printf("NO\n");
				continue;
			}
			flag = 0;
			if (map[s.x][s.y] == map[e.x][e.y] && map[s.x][s.y] != 0){
				memset(vis,0,sizeof(vis));
				vis[s.x][s.y] = 1;
				for (int i = 0; i < 4; i++){
					point tmp;
					tmp.x = s.x + dx[i];
					tmp.y = s.y + dy[i];
					if (flag == 0)
						dfs(tmp,i,0);
				}
			}
			if (flag)
				printf("YES\n");
			else printf("NO\n");
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: