您的位置:首页 > 产品设计 > UI/UE

HDU 1711 Number Sequence(KMP)

2014-03-17 14:55 351 查看


Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9548    Accepted Submission(s): 4370


Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one
K exist, output the smallest one.

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
.
The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

 

Sample Output

6
-1

 

题意: 求最先匹配的位置。

思路:第一次做KMP,这题裸题,熟悉一下。

代码:

#include <stdio.h>
#include <string.h>

const int N = 1000005;
const int M = 10005;
int n, m, seq
, seq1[M], next[M], i, t;

void get_next(int *seq, int m) {
memset(next, 0, sizeof(next));
int j = 0;
for (int i = 2; i <= m; i++) {
while (j > 0 && seq[i] != seq[j + 1])
j = next[j];
if (seq[i] == seq[j + 1]) j++;
next[i] = j;
}
}

int kmp(int *seq, int *seq1, int n, int m) {
int j = 0, ans = 0;
for (int i = 1; i <= n; i++) {
while (j > 0 && seq[i] != seq1[j + 1]) j = next[j];
if (seq[i] == seq1[j + 1]) j++;
if (j == m) {
return i - m + 1;
}
}
return -1;
}

int main() {
scanf("%d", &t);
while (t--) {
scanf("%d%d", &n, &m);
for (i = 1; i <= n; i++)
scanf("%d", &seq[i]);
for (i = 1; i <= m; i++)
scanf("%d", &seq1[i]);
get_next(seq1, m);
printf("%d\n", kmp(seq, seq1, n, m));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: