您的位置:首页 > 其它

[ACM_水题] Yet Another Story of Rock-paper-scissors [超水 剪刀石头布]

2014-03-16 16:57 447 查看
DescriptionAkihisa and Hideyoshi were lovers. They were sentenced to death by the FFF Inquisition. Ryou, the leader of the FFF Inquisition, promised that the winner of Rock-paper-scissors would be immune from the punishment. Being lovers, Akihisa and Hideyoshi decided to die together with their fists clenched, which indicated rocks in the game. However, at the last moment, Akihisa chose paper and Hideyoshi chose scissors. As a result, Akihisa was punished by the FFF Inquisition and Hideyoshi survived alone.When a boy named b and a girl named g are being punished by the FFF Inquisition, they will play Rock-paper-scissors and the winner will survive. If there is a tie, then neither of they will survive. At first, they promise to choose the same gesture x. But actually, the boy wants to win and the girl wants to lose. Of course, neither of them knows that the other one may change his/her gesture. At last, who will survive?InputThere are multiple test cases. The first line of input is an integer T ≈ 1000 indicating the number of test cases.Each test case contains three strings -- bgx. All strings consist of letters and their lengths never exceed 20. The gesture x is always one of
"rock"
,
"paper"
and
"scissors"
.OutputIf there is a tie, output
"Nobody will survive"
. Otherwise, output
"y will survive"
where y is the name of the winner.Sample Input
1
Akihisa Hideyoshi rock
Sample Output
Hideyoshi will survive

题目大意:T种情况,A,B两人商量好同时出剪刀石头或布,结果A想赢,B想输,输出最终谁赢。
解题思路:B赢

#include<iostream>
#include<string.h>
#include<cstring>
#include<string>
using namespace std;
int main(){
int T;cin>>T;
while(T--){
string str1,str2,str3;
cin>>str1>>str2>>str3;
cout<<str2<<" will survive\n";
}return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: