您的位置:首页 > 其它

HCPC2014校赛训练赛 3 B.背单词 (3.15)

2014-03-15 17:34 309 查看
B.背单词
Time Limit: 1000 MSMemory Limit: 32768 K
Total Submit: 101
(56 users)
Total Accepted: 49
(48 users)
Special Judge: No
Description
大四了,Leyni感觉好惆怅,因为找不到工作,所以最后决定考研了,可是Leyni的英语好差,没办法,先从最基本的背单词开始吧。那么多单词怎么才好背呢,话说考研界盛传利用前缀背单词,貌似好神奇的样子。因为英语单词很多,Leyni想要知道以一个特定字符串做前缀的单词有多少,于是他来找你帮忙了。
Input
输入首先包含若干行小写单词,表示字典里的单词,以END结束,然后是若干个询问字符串,表示单词的前缀。输入到文件结束。最多不超过50000个单词。每个单词长度不超过15。
Output
对于每一个询问字符串,每行输出一个整数,表示单词表里有多少单词以此字符串作为前缀。
Sample Input
a
ab
aba
abcaa
END
aba
a
ab
abcd
Sample Output
1
4
3
0
Author
曹振海
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
struct node
{
int count;
node *childs[26];
node()
{
count=0;
int i;
for(i=0;i<26;i++)
childs[i]=NULL;
}
};
node *root=new node;
node *current,*newnode;
void insert(char *str)
{
int i,m;
current=root;
for(i=0;i<strlen(str);i++)
{
m=str[i]-'a';
if(current->childs[m]!=NULL)
{
current=current->childs[m];
++(current->count);
}
else
{
newnode=new node;
++(newnode->count);
current->childs[m]=newnode;
current=newnode;
}
}
}
int search(char *str)
{
int i,m;
current=root;
for(i=0;i<strlen(str);i++)
{
m=str[i]-'a';
if(current->childs[m]==NULL)
return 0;
current=current->childs[m];
}
return current->count;
}
int main()
{
char str[20];
while(gets(str),strcmp(str,"END"))
insert(str);
while(gets(str)!=NULL)
printf("%d\n",search(str));
return 0;
}


结果:

77702BAcceptedG++32ms14792k985B2014-03-15 15:04:02
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: