您的位置:首页 > 产品设计 > UI/UE

PAT 1041. Be Unique (20) 【Hash思想】

2014-03-15 12:55 507 查看


1041. Be Unique (20)

时间限制

100 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For
example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.
Sample Input 1:
7 5 31 5 88 67 88 17

Sample Output 1:
31

Sample Input 2:
5 888 666 666 888 888

Sample Output 2:
None


提交代码

赞一个,Hash存储是个神奇的东西。。

#include<stdio.h>
#include<string.h>
const int MAX=100005;

int main()
{
//freopen("G:\\in.txt","r",stdin);
int i,n,tmp,ha[MAX],id[MAX];
while(scanf("%d",&n)!=EOF){
memset(ha,0,sizeof(ha));
for(i=0;i<n;i++){
scanf("%d",&tmp);
id[i]=tmp;
ha[id[i]]++;
}
for(i=0;i<n;i++){
if(ha[id[i]]==1){
printf("%d\n",id[i]);
break;
}
}
if(i==n)
printf("None\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: