您的位置:首页 > 其它

HDU 1002 大数问题

2014-03-15 11:17 351 查看


A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 191832 Accepted Submission(s): 36673



Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using
32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line
between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211


Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


题目大意: 很明显就是 两个数相加即可 ,这里要处理和解决的主要是大数问题:
源代码“:
import java.math.BigDecimal;
import java.io.BufferedInputStream;
import java.util.Scanner;
public class Main {

/**
* @param args
*/
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner in = new Scanner(new BufferedInputStream(System.in));
int n, num = 0;
n = in.nextInt();
while(n>=1)
{
n--;
num++;
String a = in.next();
String b = in.next();
BigDecimal big1 = new BigDecimal(a);
BigDecimal big2 = new BigDecimal(b);
BigDecimal big3;
big3 = big1.add(big2);
System.out.println("Case "+num+":");
System.out.println(a + " + " + b +" = " + big3.toString());
if(n!=0) System.out.println("");
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: