您的位置:首页 > 其它

1002 hdu (高精度)

2014-03-13 14:14 211 查看


A + B Problem II

TimeLimit: 2000/1000 MS(Java/Others)    MemoryLimit: 65536/32768 K (Java/Others)

Total Submission(s):108726    AcceptedSubmission(s): 20548


Problem Description

I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.

 

Input

The first line of the input contains an integerT(1<=T<=20) which means the number oftest cases. Then T lines follow, each line consists of two positiveintegers, A and B. Notice that the integers are very large, thatmeans you should not process them by using
32-bit integer. You mayassume the length of each integer will not exceed 1000.

 

Output

For each test case, you should output two lines. The first line is"Case #:", # means the number of the test case. The second line isthe an equation "A + B = Sum", Sum means the result of A + B. Notethere are some spaces int the equation. Output a blank line
betweentwo test cases.

 

Sample Input


2 1 2112233445566778899 998877665544332211

 

Sample Output


Case1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 =1111111111111111110

 

Author

Ignatius.L

#include <stdio.h>
#include<string.h>
int sum[1000];
void add (char a[] ,char b[])
{
int i= strlen(a) - 1 ,j = strlen (b) - 1;
int x= 0 ,s ,k = 0;
while(i >= 0 && j>= 0)
{
s = a[i--]+ b[j--] - 96 + x ;
sum[k++] =s % 10 ;
x = s / 10;
}
if (j== -1)
while(i >= 0)
{
s = a[i--] - 48 + x ;
sum[k++] = s % 10 ;
x = s / 10 ;
}
if (i== -1)
while(j >= 0)
{
s = b[j--] - 48 + x ;
sum[k++] = s % 10 ;
x = s / 10 ;
}
if(x)
sum[k]= x ;
else
k = k- 1 ;
for (i= k ;i >= 0 ;i--)
printf("%d",sum[i]);
}
int main ()
{
int t,i;
chara[1000] ,b[1000];
scanf("%d",&t);
for (i= 1 ;i <= t ;i++)
{
memset(a , '0' ,sizeof(a));
memset(b , '0' ,sizeof(b));
scanf ("%s%s",a ,b);
printf ("Case %d:\n%s + %s =",i ,a ,b);
add (a ,b);
printf ("\n");
if(i != t)printf("\n");
}
return0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: