您的位置:首页 > 其它

hdu 1051:Wooden Sticks(水题,贪心)

2014-03-11 17:30 501 查看

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10423 Accepted Submission(s): 4287


[align=left]Problem Description[/align]
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

[align=left]Input[/align]
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

[align=left]Output[/align]
The output should contain the minimum setup time in minutes, one per line.

[align=left]Sample Input[/align]

3
5
4 9 5 2 2 1 3 5 1 4
3
2
2 1 1 2
2
3
1 3 2 2 3 1

[align=left]Sample Output[/align]

2

1

3

[align=left]Source[/align]
Asia 2001, Taejon (South Korea)

[align=left]Recommend[/align]
We have carefully selected several similar problems for you: 1050 1052 1045 1053 1789

  水题。
  先对木材长度 l 排序,在对 w 依次处理,将第一个递增序列筛选出来,筛选出来的元素赋值为-1,再将第二个递增序列筛选出来,同样标记-1 ,直到w序列全部为-1,代表筛选完成。输出记录下的递增序列的个数就是结果。
  还可以用贪心做,有时间再做一遍。
  代码:

#include <iostream>

using namespace std;
struct stick{
int l,w;
}s[5010];
int main()
{
int T;
cin>>T;
while(T--){
int n;
cin>>n;
for(int i=1;i<=n;i++)
cin>>s[i].l>>s[i].w;
//对l排序
for(int i=1;i<=n-1;i++)
for(int j=1;j<=n-i;j++){
if(s[j].l>s[j+1].l){
int t;
t=s[j].l;s[j].l=s[j+1].l;s[j+1].l=t;
t=s[j].w;s[j].w=s[j+1].w;s[j+1].w=t;
}
}
int sum=0;  //递增序列的个数
//对w序列进行筛选
while(1){
int i;
for(i=1;i<=n;i++){  //如果全部为-1,则退出循环
if(s[i].w!=-1)
break;
}
if(i>n) break;
sum++;
int num=0;
for(i=1;i<=n;i++){
if(num==0 && s[i].w!=-1){
num=s[i].w;
s[i].w=-1;
}
else if(s[i].w!=-1 && s[i].w>=num){
num=s[i].w;
s[i].w=-1;
}
}
}
cout<<sum<<endl;

}
return 0;
}


Freecode : www.cnblogs.com/yym2013
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: