您的位置:首页 > 编程语言 > C语言/C++

【C++】PAT (advanced level)1033. To Fill or Not to Fill (25)*

2014-03-11 13:14 477 查看

1033. To Fill or Not to Fill (25)

时间限制
10 ms

内存限制
32000 kB

代码长度限制
16000 B

判题程序
Standard

作者
ZHANG, Guochuan

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully
design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the
average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station
and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible
distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:
749.17

Sample Input 2:
50 1300 12 2
7.10 0
7.00 600

Sample Output 2:
The maximum travel distance = 1200.00


这道题有点小难,而且时间很紧,暂时没做出来
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#include<map>
#include<iomanip>
using namespace std;

int main(){
map<float,int>aa;
map<float,int>::iterator it;
int bb[30001]={-1};
int sub[501],subn=1;

freopen("in.txt","r",stdin);
int C,ds,dr,N;
scanf("%d%d%d%d",&C,&ds,&dr,&N);
bb[0]=ds;
sub[0]=0;
int n=N;
while(n--){
float ta;
int tb;
scanf("%f%d",&ta,&tb);
aa[ta]=tb;
}
for(it=aa.begin();it!=aa.end();it++){
n=subn;
while(n--){
if(sub
<(*it).second&&bb[sub
]>(*it).second){
subn++;
bb[(*it).second]=bb[sub
];
bb[sub
]=(*it).second;
}
}
}

fclose(stdin);
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: