您的位置:首页 > 其它

[ACM] hdu 1051 Wooden Sticks

2014-03-10 20:56 441 查看

Wooden Sticks

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 5 Accepted Submission(s) : 2

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing
a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks
in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more
spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1


Sample Output

2
1
3


Source

Asia 2001, Taejon (South Korea)

解题思路:

贪心+递减子序列(严格来说是非递增子序列)。按长度从大到小排序,长度相同,按重量从大到小排序。多次寻找递减子序列,即每次都把这一个序列的木头处理掉,即启动时间+1,并把被处理掉的木头做上标记。用一个变量记录被处理掉木头的个数,多次寻找子序列,处理掉木头,当该变量的个数等于木头总数时,退出循环。

比如第一个测试数据

4 9 5 2 2 1 3 5 14

排序后,为了方便看,我们竖着写。排序后:

l w

5 2

4 9

3 5

2 1

1 4

有两个递减子序列:

5 2 2 1

4 9 3 5 1 4

代码:

#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
struct w
{
int l,w;
bool ok;//用来标记是否木头被处理掉。
}wood[5003];
bool cmp(w a,w b)//首先按长度从大到下排序,长度相同的按重量从大到小排序
{
if(a.l>b.l)
return true;
else if(a.l==b.l)
{
if(a.w>b.w)
return true;
return false;
}
return false;
}
int main()
{
int t;cin>>t;
while(t--)
{
int n;cin>>n;
for(int i=1;i<=n;i++)
{
cin>>wood[i].l>>wood[i].w;
wood[i].ok=0;//初始化木头都未处理。
}
sort(wood+1,wood+1+n,cmp);//排序。
int setup=0;int emp=0;//已经被处理的木头的个数
w temp;
while(1)
{
if(emp==n)//当所有的木头都被处理时,结束循环
break;
for(int i=1;i<=n;i++)//寻找每次机器启动,处理的那根长度最长,重量最重的那根木头。实质,多次寻找最长递减子序列,及寻找最大的那个元素
{
if(!wood[i].ok)
{
temp=wood[i];
break;//别忘了这一句
}
}
// cout<<"**"<<temp.l<<" "<<temp.w<<endl;
for(int i=1;i<=n;i++)
{
if(!wood[i].ok&&wood[i].l<=temp.l&&wood[i].w<=temp.w)//前提是该木头没有被处理,所以必须加上!wood[i].ok
{
wood[i].ok=1;//该木头被处理
emp++;
temp=wood[i];//及时更换长度最长,重量最重的那根木头,及递减子序列的当前元素的下一个元素。
}
}
setup++;//一次启动处理结束。
}
cout<<setup<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: