您的位置:首页 > 其它

POJ 2386 Lake Counting (DFS)

2014-03-10 16:57 513 查看
Description
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.').
Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3
#include <iostream>
#include <cstdio>
using namespace std;
int N,M;
char field[105][105];
void dfs(int x,int y)
{
field[x][y]='.';//相连的W赋值为'.'
for(int dx=-1;dx<=1;dx++)
{
for(int dy=-1;dy<=1;dy++)
{
int nx=x+dx; int ny=y+dy;//化成坐标
if(nx>=0&&nx<N&&ny>=0&&ny<M&&field[nx][ny]=='W')//当W在花园内时继续dfs
dfs(nx,ny);
}
}
return;
}
int main()
{
int res,i,j;
while(~scanf("%d%d",&N,&M))
{
for(i=0;i<N;i++)
for(j=0;j<M;j++)
cin>>field[i][j];
for(i=0,res=0;i<N;i++)
for(j=0;j<M;j++)
{
if(field[i][j]=='W')//深搜了几次就有几个水洼
{dfs(i,j);res++;}
}
cout<<res<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: