您的位置:首页 > 其它

2014ACM集训13级PK赛2-Median

2014-03-09 22:10 357 查看
Description

A median is described as the numeric value separating the higher half of a list, from the lower half. The median of a finite list of numbers can be found by arranging all the elements from lowest value to highest value and picking the middle one. If there
is an even number of elements, the median is then defined to be the mean of the two middle values. Now, could you write a program to help to find the median?

Input

There are multiple test cases. The first line of input is an integer T ≈ 100 indicating the number of test cases.

The first line of each test is an integer 0 < n < 500 indicating the number of elements. The second line consists of n numbers, the elements of the list, whose absolute values are
smaller than 1,000,000.

Output

For each test case, output the median, with 3 decimal digits.

Sample Input

3
1
0.0
4
1.0 1000.3 100.2 10.1
5
2.0 3.0 5.0 7.0 11.0


Sample Output
0.00055.1505.000
References

http://en.wikipedia.org/wiki/Median

 

 

#include <stdio.h>
#include <stdlib.h>

int cmp (const void *a,const void *b)
{
return *(double *)a - *(double *)b;
}

double num[1000];
int main()
{
int N;
scanf ("%d",&N);
while (N--)
{
int n,i;
scanf ("%d",&n);
for (i = 0;i < n;i++)
scanf ("%lf",&num[i]);
qsort(num,n,sizeof (double),cmp);

if (n % 2)
{
int z = ((n - 1) / 2);
printf ("%.3lf\n",num[z]);
}else
{
int z1 = n / 2 - 1;
int z2 = z1 + 1;
printf ("%.3lf\n",(num[z1] + num[z2])/2);
}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: