您的位置:首页 > 编程语言 > Java开发

2014ACM集训13级PK赛2-Javabeans

2014-03-09 22:09 309 查看
Description

Javabeans are delicious. Javaman likes to eat javabeans very much.

Javaman has n boxes of javabeans. There are exactly i javabeans in the i-th box (i = 1, 2, 3,...n). Everyday Javaman chooses
an integer x. He also chooses several boxes where the numbers of javabeans are all at least x. Then he eats x javabeans in each box he has just chosen. Javaman wants to eat
all the javabeans up as soon as possible. So how many days it costs for him to eat all the javabeans?

Input

There are multiple test cases. The first line of input is an integer T ≈ 100 indicating the number of test cases.

Each test case is a line of a positive integer 0 < n < 231.

Output

For each test case output the result in a single line.

Sample Input

4
1
2
3
4


Sample Output

1223
 

#include <stdio.h>

int main()
{
int N;
int i;

scanf ("%d",&N);
while (N--)
{
int n;
int ans = 1;

scanf ("%d",&n);
int s;
while (1)
{
if (ans == 1)
n = n / 2 + 1;
else
n = (n - 1) / 2 + 1;
if (n == 1)
{
s = 0;
break;
}
if (n == 2)
{
s = 1;
break;
}else if (n == 3)
{
s = 2;
break;
}
ans++;
}
printf ("%d\n",s + ans);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: