您的位置:首页 > 其它

HDU 1880 魔咒词典

2014-03-09 17:27 393 查看


魔咒词典

Time Limit: 8000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9365 Accepted Submission(s): 2402



Problem Description

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”



Input

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。

词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。



Output

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”



Sample Input

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky




Sample Output

light the wand
accio
what?
what?




Author

ZJU



Source

浙大计算机研究生复试上机考试-2008年



这个题一直是用map写的,在别的两个平台上都能AC,但就是在HDU上内存超出。所以尝试用最简单的查找,结果竟然过了,有时候真得好好对待stl,在stl超时的时候可以考虑用原始的方法写写。

#include <cstdio>
#include <cstdlib>
#include <map>
#include <iostream>
#include <cstring>
#include <string>

using namespace std;

const int maxx = 100002;
typedef struct DIC{
	char ti[21];
	char func[81];
}DIC;

DIC dic[maxx];
char st,title[21],func[82],laji[20],qur[82];
int m;

int main(){
	//freopen("in.txt", "r", stdin);
	//freopen("out.txt", "w", stdout);

	int pos = 0,len,i,j;
	bool flg;
	while(scanf("%c",&st) && st=='['){
		scanf("%[^\]]%*c%*c",title);
		scanf("%[^\n]%*c",func);
		//printf("%s %s\n",title,func);
		strcpy(dic[pos].ti,title);
		strcpy(dic[pos].func,func);
		++pos;
	}

	scanf("%[^\n]%*c",laji);
	scanf("%d%*c",&m);
	for(i=0;i<m;++i){
		scanf("%[^\n]%*c",qur);
		len = strlen(qur);
		if(qur[0]=='['){
			qur[len-1]='\0';
			flg = true;
			for(j=0;j<pos;++j){
				if(strcmp(qur+1,dic[j].ti)==0){
					flg = false;
					printf("%s\n",dic[j].func);
					break;
				}
			}
			
		}else{
			flg = true;
			for(j=0;j<pos;++j){
				if(strcmp(qur,dic[j].func)==0){
					flg = false;
					printf("%s\n",dic[j].ti);
					break;
				}
			}
		}
		if(flg){
			printf("what?\n");
		}
	}
	return 0;
}


1029:魔咒词典 题目2094:魔咒词典
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: