您的位置:首页 > 其它

Ice_cream's world I hdu 2120 并查集判断环

2014-03-09 12:00 489 查看


Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 483    Accepted Submission(s): 262


Problem Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world.
But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

 

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and
B are distinct). Terminate by end of file.

 

Output

Output the maximum number of ACMers who will be awarded.

One answer one line.

 

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

 

Sample Output

3

 

Author

Wiskey

 

Source

HDU 2007-10 Programming Contest_WarmUp

 

Recommend

威士忌   |   We have carefully selected several similar problems for you:  2118 2126 2129 2133 2925 

这个题目是问墙能最多围成几组地,其实是去求到底有几个环,那到底是怎么判断
有几个环呢,用并查集,为啥子用并查集,举个大家熟悉的例子,当我们用Kruscal算法时其中有一个过程就是在不断的判断我们是不是可以构成环,所以逆着想就可以想到我们要用这个了。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define  M 2000
int n,m;
int fa[M];

int find(int x)
{
if(x!=fa[x])
{

fa[x]=find(fa[x]);
}
return fa[x];
}

int main()
{

int i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{

for(i=0;i<n;i++)
fa[i]=i;
int ans=0;
int a,b;
while(m--)
{
scanf("%d%d",&a,&b);
int x=find(a);
int y=find(b);
if(x==y)
ans++;
else
fa[x]=y;

}
printf("%d\n",ans);

}

return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息