您的位置:首页 > 其它

hdu 1358 Period (KMP)

2014-03-09 12:00 381 查看

Period

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2402 Accepted Submission(s): 1191


[align=left]Problem Description[/align]
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

[align=left]Input[/align]
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

[align=left]Output[/align]
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

[align=left]Sample Input[/align]

3
aaa
12
aabaabaabaab
0

[align=left]Sample Output[/align]

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

[align=left]Recommend[/align]
JGShining | We have carefully selected several similar problems for you: 3746 1277 2896 3065 1298

//109MS    5116K    636 B    G++
/*

题意:
给出一字符串,找出由两个或以上相同的子字符串组成的前缀,
输出前缀长度及其中相同的子字符串数

KMP:
这是一题对next数组的应用的题,首先常规求出next数组,然后

式子 :  i%temp==0 && i/temp>1

为关键的判断句,具体理解可以找实例试试

*/
#include<stdio.h>
int next[1000005];
int Get_next(char c[],int n)
{
int i=0,j=-1;
next[0]=-1;
while(i<n){
if(c[i]==c[j] || j==-1){
i++;j++;next[i]=j;
}
else j=next[j];
}
}
int main(void)
{
int n,k=1;
char c[1000005];
while(scanf("%d",&n),n)
{
scanf("%s",c);
Get_next(c,n);
printf("Test case #%d\n",k++);
for(int i=1;i<=n;i++)
{
int temp=i-next[i];
if(i%temp==0 && i/temp>1)
printf("%d %d\n",i,i/temp);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: