您的位置:首页 > 编程语言 > C语言/C++

UVA10004Bicoloring(DFS)二分染色

2014-03-08 23:37 239 查看


  Bicoloring 
In 1976 the ``Four Color Map Theorem" was proven with the assistance of a computer. This theorem states that every map can be colored using only four colors, in such a way that no region is colored using the
same color as a neighbor region.
Here you are asked to solve a simpler similar problem. You have to decide whether a given arbitrary connected graph can be bicolored. That is, if one can assign colors (from a palette of two) to the nodes in such
a way that no two adjacent nodes have the same color. To simplify the problem you can assume:

no node will have an edge to itself.
the graph is nondirected. That is, if a node a is said to be connected to a node b, then you must assume that b is connected to a.
the graph will be strongly connected. That is, there will be at least one path from any node to any other node.

Input 

The input consists of several test cases. Each test case starts with a line containing the number n ( 1
< n< 200) of different nodes. The second line contains the number of edges l.
After this, l lines will follow, each containing two numbers that specify an edge between the two nodes that they represent. A node in the graph
will be labeled using a number a ( 

).
An input with n = 0 will mark the end of the input and is not to be processed.

Output 

You have to decide whether the input graph can be bicolored or not, and print it as shown below.

Sample Input 

3
3
0 1
1 2
2 0
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
0


Sample Output 

NOT BICOLORABLE.
BICOLORABLE.

这个题的思路是从0点开始搜索,如果没有染色,就染上与上一个不同的颜色,如果已染色,就判断与上一个颜色是否相同,若相同则说明矛盾,不能二分染色。

#include <stdio.h>
#include <string.h>
int map[210][210], color[210];
int dfs(int x, int n)
{
int i;
color[0]=1;
for(i=0; i<n; i++)
{
if(!color[i]&&map[x][i])
{
color[i]=-color[x];
if(dfs(i,n))
return 1;
else
return 0;
}
else if(color[i]&&map[x][i]&&color[x]==color[i])
{
return 0;
}
}
return 1;
}
int main()
{
int n, m, i, j, a, b;
while(scanf("%d",&n)!=EOF&&n)
{
scanf("%d",&m);
memset(color,0,sizeof(color));
memset(map,0,sizeof(map));
while(m--)
{
scanf("%d%d",&a,&b);
map[a][b]=1;
map[b][a]=1;
}
if(dfs(0,n))
printf("BICOLORABLE.\n");
else
printf("NOT BICOLORABLE.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息