您的位置:首页 > 其它

九度oj 题目1464:Hello World for U 【ZJU2012考研机试题1】

2014-03-07 22:07 302 查看
题目1464:Hello World for U

时间限制:1 秒

内存限制:128 兆

特殊判题:否

提交:2517

解决:694

题目描述:

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h d

e l

l r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And
more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入:

There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出:

For each test case, print the input string in the shape of U as specified in the description.

样例输入:
helloworld!
ac.jobdu.com


样例输出:
h   !
e   d
l   l
lowor
a    m
c    o
.    c
jobdu.


来源:
2012年浙江大学计算机及软件工程研究生机试真题

由于3条边,尽量是方形,故必然可以mod3然后微调。输出按行控制补空格即可。

/**************************************************************
Problem: 1464
Language: C++
Result: Accepted
Time:10 ms
Memory:1020 kb
****************************************************************/
#include <stdio.h>
#include<string.h>
const int MAX=100;

int main()
{
int n1,n2,n3,i,j;
char str[MAX];
//freopen("G:\\in.txt","r",stdin);
//-------------------进行输入----------------------
while(scanf("%s",str)!=EOF){
int len=strlen(str);
if(len%3!=0){
n1=len/3+1;
n3=len/3+1;
n2=len+2-n1*2;
}
else{
n1=len/3;
n3=len/3;
n2=len+2-n1-n3;
}
for(i=0;i<n1-1;i++){
printf("%c",str[i]);
for(j=0;j<n2-2;j++)
printf(" ");
printf("%c\n",str[len-1-i]);
}
for(i=n1-1;i<n1+n2-1;i++)
printf("%c",str[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: