您的位置:首页 > 其它

九度oj 题目1004:Median 【ZJU2011考研机试题3】

2014-03-07 17:38 423 查看
题目1004:Median

时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:10604

解决:2896

题目描述:

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences
is defined to be the median of the non-decreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

输入:

Each input file may contain more than one test case.

Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤1000000) is the size of that sequence. Then N integers follow, separated by a space.

It is guaranteed that all the integers are in the range of long int.

输出:

For each test case you should output the median of the two given sequences in a line.

样例输入:
4 11 12 13 14
5 9 10 15 16 17


样例输出:
13


来源:2011年浙江大学计算机及软件工程研究生机试真题

答疑:
解题遇到问题?分享解题心得?讨论本题请访问:http://t.jobdu.com/thread-7728-1-1.html

法1:sort排序。空间开的够大,注意下标要不要减1!!

#include <stdio.h>
#include<algorithm>
using namespace std;
int a[2000100];
int main()
{
int n,m,i;
//freopen("G:\\in.txt","r",stdin);
while(scanf("%d",&n)!=EOF){
for(i=0;i<n;i++)
scanf("%d",&a[i]);
scanf("%d",&m);
for(i=n;i<m+n;i++)
scanf("%d",&a[i]);
sort(a,a+m+n);
printf("%d\n",a[(m+n-1)/2]); //注意啦:此处要减掉1,不然老报错。。。
}
return 0;
}


法2:merge两个有序表(优化)。

/**************************************************************
Problem: 1004
Language: C++
Result: Accepted
Time:0 ms
Memory:16644 kb
****************************************************************/
#include <stdio.h>
#include<algorithm>
using namespace std;
int a[1000010],b[1000010],c[2000010];
void merge(int t1[],int t2[],int n1,int n2)
{
int i=0,j=0,k=0;
while(i<n1&&j<n2){
if(t1[i]<=t2[j]){
c[k]=t1[i];
i++;k++;
}
else{
c[k]=t2[j];
j++;k++;
}
}
if(i==n1)
c[k++]=t2[j++];
if(j==n2)
c[k++]=t1[i++];
}
int main()
{
int n,m,i;
//freopen("G:\\in.txt","r",stdin);
while(scanf("%d",&n)!=EOF){
for(i=0;i<n;i++)
scanf("%d",&a[i]);
scanf("%d",&m);
for(i=0;i<m;i++)
scanf("%d",&b[i]);
merge(a,b,n,m);
printf("%d\n",c[(m+n-1)/2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: