您的位置:首页 > 其它

九度oj 题目1002:Grading 【ZJU2011考研机试题2】

2014-03-07 17:09 375 查看
题目1002:Grading

时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:12481

解决:3212

题目描述:

Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other,
a judge is invited to make the final decision. Now you are asked to write a program to help this process.

For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:

• A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.

• If the difference exceeds T, the 3rd expert will give G3.

• If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.

• If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.

• If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

Each input file may contain more than one test case.

Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18


样例输出:
14.0


来源:2011年浙江大学计算机及软件工程研究生机试真题

答疑:解题遇到问题?分享解题心得?讨论本题请访问:http://t.jobdu.com/thread-7726-1-1.html

分情况讨论:与 在或之前讨论

/**************************************************************
Problem: 1002
Language: C++
Result: Accepted
Time:0 ms
Memory:1020 kb
****************************************************************/
#include <stdio.h>
bool check(int m,int n,int t)
{
if(m-n>=-t&&m-n<=t)
return true;
return false;
}
int maxOf3(int a,int b,int c)
{
int maxTmp=-100000;
if(a>maxTmp)
maxTmp=a;
if(b>maxTmp)
maxTmp=b;
if(c>maxTmp)
maxTmp=c;
return maxTmp;
}
int main()
{
int full,tol,g1,g2,g3,gl;
//freopen("G:\\in.txt", "r", stdin);
while(scanf("%d%d%d%d%d%d",&full,&tol,&g1,&g2,&g3,&gl)!=EOF){
bool q1=check(g1,g2,tol);
if(q1==1)
printf("%.1lf\n",(double)(g1+g2)/2);
else{
bool q2=check(g1,g3,tol);
bool q3=check(g2,g3,tol);
if(q2==1&&q3==1)
printf("%.1lf\n",(double)maxOf3(g1,g2,g3)/2);
else if(q2==1)
printf("%.1lf\n",(double)(g1+g3)/2);
else if(q3==1)
printf("%.1lf\n",(double)(g2+g3)/2);
else
printf("%.1lf\n",(double)gl);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: