您的位置:首页 > 其它

九度oj 题目1001:A+B for Matrices 【ZJU2011考研机试题1】

2014-03-07 16:44 375 查看
题目1001:A+B for Matrices

时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:11539

解决:4694

题目描述:

This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers
in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

The input is terminated by a zero M and that case must NOT be processed.

输出:

For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0


样例输出:
1
5


来源:2011年浙江大学计算机及软件工程研究生机试真题

答疑:解题遇到问题?分享解题心得?讨论本题请访问:http://t.jobdu.com/thread-7724-1-1.html

对二维数组的遍历

/**************************************************************
Problem: 1001
Language: C++
Result: Accepted
Time:0 ms
Memory:1080 kb
****************************************************************/
#include <stdio.h>
#include<string.h>
const int MAX=1000;
int ans[MAX][15],cnt;
int main()
{
int n,m,tmp,i,j;
//freopen("G:\\in.txt", "r", stdin);
while(scanf("%d%d",&n,&m)!=EOF){
if(n==0) break;
for(i=0;i<n;i++){  //输入n行作为矩阵A
for(j=0;j<m;j++)
scanf("%d",&ans[i][j]);
}
for(i=0;i<n;i++){  //输入n行作为矩阵A+B
for(j=0;j<m;j++){
scanf("%d",&tmp);
ans[i][j]+=tmp;
}
}
cnt=0;
for(i=0;i<n;i++){
for(j=0;j<m;j++){
if(ans[i][j]!=0)
break;
}
if(j==m)
cnt++;
}
for(i=0;i<m;i++){
for(j=0;j<n;j++){
if(ans[j][i]!=0)
break;
}
if(j==n)
cnt++;
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: