您的位置:首页 > 其它

poj 3349(hash)

2014-03-05 17:59 232 查看
很久就听说过hash了,但是一直没有做过相关的题目。

题意大概就是给你n个雪花,每个雪花有六个花瓣代表六个值,判断是否有至少一对相同的雪花。

由于n值较大,而且每次要判断6个数,我开始根据我自己学的一点hash的知识,先存起来,然后求6个值的和取余一个值,存在一个数组里面,然后每次向前找所有的如果有相同的,则比较六个值,超时了。后来看了别人的写法,发现弱爆了。那样找的话很慢。

其实差别就在存的时候,每一个雪花求和取余一个数,作为建值,如果有相同的在键值后面保存起来,没次值找键值里面的,快速了很多。

题目:

Snowflake Snow Snowflakes

Time Limit: 4000MSMemory Limit: 65536K
Total Submissions: 28891Accepted: 7622
Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake
has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six
integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms.
For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:

No two snowflakes are alike.

If there is a pair of possibly identical snow akes, your program should print the message:

Twin snowflakes found.

Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output
Twin snowflakes found.

代码:这里是用数组实现的,内存有要求的题目需要用链表实现

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int K = 14997;

struct Node
{
    int floor[7];
};
int m[15000];
Node snow[15000][100];
bool solve(Node x,Node y)  //比较
{
    sort(x.floor,x.floor+6);
    sort(y.floor,y.floor+6);
    for(int i=0;i<6;i++)
    {
        if(x.floor[i]!=y.floor[i])
            return false;
    }
    return true;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(m,0,sizeof(m));
        int ok=0;
        for(int i=0; i<n; i++)
        {
            int sum=0;
            Node pp;
            for(int j=0; j<6; j++)
            {
                scanf("%d",&pp.floor[j]);
                sum=(sum+pp.floor[j])%14997;
            }
            if(ok==0)
            {
                for(int j=0; j<m[sum]; j++) //按键值查找
                {
                    if(solve(pp,snow[sum][j])){
                        ok=1;break;
                    }
                }
                snow[sum][m[sum]]=pp;
                m[sum]++;
            }
        }
        if(ok)
            printf("Twin snowflakes found.\n");
        else
            printf("No two snowflakes are alike.\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: