您的位置:首页 > 产品设计 > UI/UE

POJ 2524 Ubiquitous Religions(并查集)

2014-03-05 16:52 267 查看
链接:http://poj.org/problem?id=2524

Ubiquitous Religions

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 21949 Accepted: 10770
Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask
m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound
of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The
end of input is specified by a line in which n = m = 0.
Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output
Case 1: 1
Case 2: 7


The Submitted Code :

#include <iostream>
#include <cstdio>
#include <cstdlib>
#define MAXN 50005
using namespace std;

int father[MAXN], N[MAXN], MaxNum;

void Make_Set(int n)
{
for(int i=1; i<=n; i++) {
father[i] = i; //使用本身做根;每一个成员开始的父亲节点都为自身;
N[i] = 1;
}
}

int Find_Set(int x)
{
if(x != father[x]) { //合并后树的根是不变的;
father[x] = Find_Set(father[x]);
}
return father[x];
}

void Union_Set(int x, int y)
{
x = Find_Set (x);
y = Find_Set (y);
if(x == y) return ;
if(x >= y) {
father[y] = x;
N[x] += N[y];
MaxNum--;
} else {
father[x] = y;
N[y] += N[x];
MaxNum--;
}
}

int main()
{
int n, m, k = 1;

while(~scanf("%d %d", &n, &m) && n || m) {
Make_Set(n);
MaxNum = n;
for(int i=0; i<m; i++) {
int Md, ME;
scanf("%d %d", &Md, &ME);
Union_Set(Md, ME); //对属于同一个小组的成员集合进行合并;
}
printf("Case %d: %d\n", k++, MaxNum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: