您的位置:首页 > 其它

ZOJ 2850 Beautiful Meadow

2014-03-05 10:37 232 查看


Tom's Meadow

Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

Not all squares are covered with grass.
No two mowed squares are adjacent.

Two squares are adjacent if they share an edge. Here comes the problem: Is Tom's meadow beautiful now?

Input

The input contains multiple test cases!

Each test case starts with a line containing two integers N, M (1 <=
N, M <= 10) separated by a space. There follows the description of Tom's Meadow. There're
N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

A line with N = 0 and M = 0 signals the end of the input, which should not be processed

Output

One line for each test case.

Output "Yes" (without quotations) if the meadow is beautiful, otherwise "No"(without quotations).

Sample Input

2 2

1 0

0 1

2 2

1 1

0 0

2 3

1 1 1

1 1 1

0 0

Sample Output

Yes

No

No

题目不难,但判断的逻辑需要好好理顺:

下面两种情况都是不漂亮的,除此之外的任何情况,都是漂亮的:

1.全是1,不漂亮。这样就包括一种情况,整个草坪只有一个方块,如果方块的草没有被剪去,那就不漂亮。

2.两个方块共一条边,即前后两个元素或者上下两个元素都是 00.

代码如下:

#include<iostream>
#include<vector>
#include<algorithm>
#include<functional>
#include<iterator>
#include<cstdio>
#include<queue>
using namespace std;
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("D:\\in.txt", "r", stdin);
freopen("D:\\out.txt", "w", stdout);
#endif // ONLINE_JUDEG
int n(0), m(0);
bool flag=true;
int p[10][10];
while (cin >> n >> m)
{
if (n == 0 && m == 0)
return 0;
flag = true;
for (int i = 0; i < n; i++)
for (int j = 0; j < m; j++)
{
cin >> p[i][j];
if (p[i][j] == 0)
flag = false;
}
if (flag == true)
{
cout << "No" << endl;
goto RL;
}
for (int j = 1; j < m; j++)//处理第一行
{
if (p[0][j] == 0 && p[0][j - 1] == 0)
{
cout << "No" << endl;
goto RL;
}
}
for (int i = 1; i < n; i++)//处理从第二行到第n-1行
for (int j = 0; j < m; j++)
{
//本行与上一行同一列元素都是0吗?
if (p[i][j] == 0 && p[i - 1][j] == 0)
{
cout << "No" << endl;
goto RL;
}
//本行中当前元素和前一元素都是0吗?
if (j != 0)
{
if (p[i][j] == 0 && p[i][j - 1] == 0)
{
cout << "No" << endl;
goto RL;//结束
}
}
}
cout << "Yes" << endl;
continue;
RL:
continue;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: