您的位置:首页 > 其它

九度oj 题目1029:魔咒词典 【ZJU2008考研机试题4】

2014-03-04 18:30 337 查看
题目1029:魔咒词典

时间限制:5 秒

内存限制:32 兆

特殊判题:否

提交:3356

解决:956

题目描述:
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

输入:

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。

词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出:
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

样例输入:
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky


样例输出:
light the wand
accio
what?
what?


来源:2008年浙江大学计算机及软件工程研究生机试真题

答疑:解题遇到问题?分享解题心得?讨论本题请访问:http://t.jobdu.com/thread-7753-1-1.html

注意:定义整形的变量
int i ,一不小心混到char里面,


搞成char i ,这样各函数单步调试,排错了个小时

绝望的找不出错误,不想再弄这题,结果突然发现,

变量的定义类型不对!!!

竟然坑在如此低级错误上。。一定别偷懒。。。。。

/*

*/
#include <stdio.h>
#include<string.h>
const int MAX=100010;
int cnt=0;  //注意一定要全局变量,不要在主函数中重新定义。。
char a[MAX][30];
char b[MAX][90];
char es[30];
char* escape(char t[])
{
int i,j=0,len1=strlen(t);
for(i=0;i<30;i++)
es[i]=0;
for(i=1;i<len1-1;i++)
es[j++]=t[i];
return es;
}
void storage(char tmp[])
{
char tmp1[30],tmp2[90];
int i=0,j=0,len2=strlen(tmp);
while(tmp[i+1]!=']'){
tmp1[i]=tmp[i+1];
i++;
}
tmp1[i]=0;
strcpy(a[cnt],tmp1);
i=i+3;//i指向一行后半个串。
for(;i<len2;i++)
tmp2[j++]=tmp[i];
tmp2[j]=0;
strcpy(b[cnt],tmp2);
cnt++;
}
void query(char q[])
{
char tmp3[30];
int i;
if(q[0]=='['){
strcpy(tmp3,escape(q));
for(i=0;i<cnt;i++){
if(strcmp(tmp3,a[i])==0){
printf("%s\n",b[i]);
break;
}
}
if(i==cnt)
printf("what?\n");
}
else{
for(i=0;i<cnt;i++){
if(strcmp(q,b[i])==0){
printf("%s\n",a[i]);
break;
}
}
if(i==cnt)
printf("what?\n");
}
}

int main()
{
char str[130];
int i,num;  //晕。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。。
//freopen("G:\\in.txt","r",stdin);
while(gets(str)){
if(strcmp(str,"@END@")==0)
break;
storage(str);
}
scanf("%d",&num);
getchar();  //输入数字后要想输入字符串需要加个getchar()!!!
if(num==0)
return 0;
for(i=0;i<num;i++){
gets(str);
query(str);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: