您的位置:首页 > 其它

UVA OJ 674 - Coin Change 解题报告

2014-03-03 23:23 253 查看

原题:

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with
the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input:

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output:

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input:


11
26

Sample Output:

4

13

中文意思:

   就是给定你一个钱的总额,总共有五种硬币的金额,分别是1,5,10,25,50,然后是问你有多少种的组合方式可以让这些钱组成给定的金额。

思路:

     其实我也没有想太多了,因为现在是在看白书,然后这个也就是DP后面的习题,所以直接DP咯,DP主要就是状态转移咯,这个是核心,所以这道题的状态转移其实我想了很久,有点失败,刚学DP,新手。

     分析:

        1.只使用硬币面额为一的,多少金额,表示这个情况下的方案数

        2.使用面额为一,五的,多少金额,表示这个情况下的方案数

        3.使用面额为一,五,十的,多少金额,表示这个情况下的方案数

        4.使用面额为一,五,十,二十五的,多少金额,表示这个情况下的方案数

             5.使用面额为一,五,十,二十五,五十的,多少金额,表示这个情况下的方案数

    状态转移:

          如使用面额一,五的,就可以通过使用面额为一的进行转移,i-k*coin[j]表示总共的金额,j表示使用的面额数,coin[j]表示面额五,k表示从0遍历到i-k*coin[j]<0为止。

           result[i][j] += result[i-k*coin[j]
4000
][j-1];

   AC代码:

#include<iostream>

using namespace std;

const int coin[] = {1,5,10,25,50};
int result[7510][6];

void makeTable(){
for (int j=1;j<5;j++) {
for (int i=1;i<=7500;i++) {
for (int k=0;k*coin[j]<=i;k++) {
result[i][j] += result[i-k*coin[j]][j-1];
}
}
}
}

int main(){

memset(result,0,sizeof(result));
for (int i=0;i<=7500;i++) result[i][0] = 1;
for (int i=0;i<5;i++) result[0][i] = 1;
makeTable();
int money = 0;
while(cin>>money) {
cout<<result[money][4]<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM DP