您的位置:首页 > 其它

浙大PAT 1031. Hello World for U (20)

2014-03-03 16:35 579 查看


1031. Hello World for U (20)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:
h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1characters, then left to right along the bottom line with n2 characters, and
finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 =
max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.
Sample Input:
helloworld!

Sample Output:
h   !
e   d
l   l
lowor


关键是求出n1与n2,数据量最大在80,所以求n1与n2时直接暴力求解即可!

#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;

int main(){
	int a,amax,b,k,len,i,j;
	char str[100];
	
	scanf("%s",str);
	len = strlen(str);
	amax = -1;
	for(b=3;b<=len;++b){
		for(a=1;a<=b;++a){
			if(2*a+b-2==len){
				if(a>amax)amax = a;
				continue;
			}
		}
	}

	a = amax;
	b = len+2-2*a;

	for(i=0;i<a-1;++i){
		cout<<str[i];
		for(j=0;j<b-2;++j){
			cout<<' ';
		}
		cout<<str[len-i-1]<<endl;
	}
	str[len-i]='\0';
	cout<<str+i<<endl;
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: