您的位置:首页 > 编程语言 > C语言/C++

【C++】PAT(advanced level)1054. The Dominant Color (20)

2014-03-03 14:36 393 查看

1054. The Dominant Color (20)

时间限制
100 ms

内存限制
32000 kB

代码长度限制
16000 B

判题程序
Standard

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. Astrictly dominant color takes
more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is
guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:
24


1.这个人的算法很巧妙.http://blog.csdn.net/zhu_liangwei/article/details/9734671

但是题目换一点就不适用了,太强调技巧性。

2.这个人用到了map我看看map怎么用

/article/9555400.html

map好用到让我感动死了。

#include<iostream>
#include<string>
#include<map>
using namespace std;

int main()
{
int a,b;
cin>>a>>b;
map<int,int> ans;
map<int,int>::iterator p;
int i,j;
for(i=0;i<b;i++){
for(j=0;j<a;j++){
int temp;
scanf("%d",&temp);
//cout<<ans[temp];
ans[temp]++;
}
}
int max=-1,color;
for(p=ans.begin();p!=ans.end();p++){
if(p->second>max){
color=p->first;
max=p->second;
}
}
cout<<color;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: