您的位置:首页 > 其它

hdu——1051——Wooden Sticks

2014-03-02 14:16 447 查看
Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case,
and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3

5

4 9 5 2 2 1 3 5 1 4

3

2 2 1 1 2 2

3

1 3 2 2 3 1

Sample Output

2

1

3

题意:输入n个木棍,每一个木棍都有一定的长度和重量,机器每次都对一个木棍进行处理,每次需要一分钟,如果后面的长度和重量大于或等于前面的,则时间不用加一分钟

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
struct node
{
int L;
int w;
int vis;
}Node[5005];
int cmp(node a,node b)
{
if(a.L!=b.L)
return a.L<b.L;
else
return a.w<b.w;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
cin>>Node[i].L>>Node[i].w;
Node[i].vis=0;
}
sort(Node,Node+n,cmp);
int sum=0;
for(int i=0;i<n;i++)
{
if(Node[i].vis)
continue;
sum++;
Node[i].vis=1;
int weight=Node[i].w;
for(int j=i+1;j<n;j++)
{
if(!Node[j].vis&&Node[j].w>=weight)
{
Node[j].vis=1;
weight=Node[j].w;
}
}
}
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: