您的位置:首页 > 其它

pojJoseph 约瑟夫环问题

2014-02-28 19:08 369 查看
Joseph

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 46332Accepted: 17459
Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved.
Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
Output

The output file will consist of separate lines containing m corresponding to k in the input file.
Sample Input
3
4
0

Sample Output
5
30


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include<iostream>
using namespace std;
int main ()
{
// freopen ("t.txt", "r", stdin);
int k, answer;//答案
int count;//计数去掉了几个人
int next;//下一个要去掉的人的编号 0~2k-1
int rest;//去掉剩下几个人了
int cache[20];//如果不缓存计算结果会TLE||
memset(cache, 0, sizeof(cache));
while (scanf("%d", &k) != EOF && k != 0)
{
answer = k;
while (!cache[k])
{
count = 0;  rest = 2*k;  answer++;  next = 0;
//cout<<"answer="<<answer<<endl;
while(1)
{
if (count == k)
{
cache[k] = answer;  break;
}
next = (next + answer - 1) % rest;
//cout<<"next="<<next<<endl;
if (next < k) //因为好人不会先去掉,所以直接判断去掉的人编号是不是属于0~k-1的
break;
count++;  rest--;
}
}
printf("%d\n", cache[k]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: