您的位置:首页 > 编程语言 > C语言/C++

Pat(Advanced Level)Practice--1067(Sort with Swap(0,*))

2014-02-28 17:31 351 查看

Pat1067代码

题目描述:

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following
way:

Swap(0, 1) => {4, 1, 2, 0, 3}

Swap(0, 3) => {4, 1, 2, 3, 0}

Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.
Sample Input:
10 3 5 7 2 6 4 9 0 8 1

Sample Output:
9


AC代码:
#include<cstdio>
#define N 100005

using namespace std;

int Check(int A[],int begin,int end)//check the position of the data
{
int i;
for(i=begin;i<=end;i++)
if(A[i]!=i)
return i;
return 0;
}

int main(int argc,char *argv[])
{
int i,n;
int Array
;
int ans=0,temp;
int index;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&Array[i]);
index=Check(Array,1,n-1);
while(index)
{
if(Array[0]==0)//如果0的位置是正确地,则将它与任何一个位置不正确
{     //的元素交换,然后将Array[0]指向位置的元素调整正确,
Array[0]=Array[index];//在此过程中0可能回到正确位置
Array[index]=0;//如此循环即可
ans++;
}
while(Array[0]!=0)
{
temp=Array[0];
Array[0]=Array[temp];
Array[temp]=temp;
ans++;
}
index=Check(Array,index,n-1);
}
printf("%d\n",ans);

return 0;
}

解题思路:
分两种情况:1)A[0]!=0,则需要将元素0与所在位置元素进行交换,例如(4,0,2,1)那么0与1交换变成(4,1,2,0),如此循环下去,可是这样并不好操作每次都需要查找元素的位置进行交换,于是换一种思路:直接与A[0]进行交换,其结果是一样的。
2)A[0]==0,则只需将元素0与任何一个位置不正确的元素进行交换即可,然后重复第一种情况的操作。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Advance Pat C++ 基础题