您的位置:首页 > 其它

POJ 1163 The Triangle (简单DP)

2014-02-26 18:06 471 查看
Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.
Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output
30

从上往下推:
#include <iostream>
#include <cstring>
using namespace std;

int main()
{
int data[105][105],dp[105][105];
int n,i,j,t;
while(cin>>n)
{
memset(data,0,sizeof(data));//初始化data
memset(dp,0,sizeof(dp));//初始化dp
cin>>data[1][1];
for(i=2,dp[1][1]=data[1][1];i<=n;i++)
for(j=1;j<=i;j++)
{
cin>>data[i][j];
dp[i][j]=max(dp[i-1][j-1],dp[i-1][j])+data[i][j];//方程,求出子问题的最优解
}
for(i=1,t=0;i<=n;i++)//从最后一行选出最大的值输出
if(t<=dp
[i])
t=dp
[i];
cout<<t<<endl;
}
return 0;
}


从下往上推:

#include <iostream>
#include <cstring>
using namespace std;
int main()
{
int i,j,n;
int data[360][360],dp[360][360];
while(cin>>n)
{
memset(data,0,sizeof(data));
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
cin>>data[i][j];
for(i=n;i>0;i--)
for(j=1;j<=i;j++)
dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+data[i][j];
cout<<dp[1][1]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: