您的位置:首页 > 其它

poj 2001 Shortest Prefixes 还不是很没明白,还得再理解理解

2014-02-25 20:48 501 查看
题目链接

Description
A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem,
but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word
the shortest prefix that uniquely identifies the word it represents.

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list
that begins with "car".

Input
The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity)
identifies this word.
Sample Input
carbohydrate
cart
carburetor
caramel
caribou
carbonic

cartilage

carbon

carriage

car

carcarbonate


Sample Output
carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

#include<stdio.h>
#include<string.h>
struct node
{
int count;
node *next[26];
} root,Root[26000];
int big=0;
char work[1010][21];
void buildTree(char *root1)
{
node  *start=&root;
while(*root1)
{
if(start->next[*root1-'a']==NULL)
{
Root[big].count=0;
start->next[*root1-'a']=&Root[big++];
}
start=start->next[*root1-'a'];
start->count++;
root1++;
}
return ;
}
void search(char *root1)
{
node *start=&root;
while(*root1)
{
if(start->count==1)
break;
printf("%c",*root1);
start=start->next[*root1-'a'];
if(start==NULL)
break;
root1++;
}
}
int main()
{
int k=0;
while(scanf("%s",work[k])!=EOF)
{
buildTree(work[k]);
k++;
}
for(int i=0; i<k; i++)
{
printf("%s ",work[i]);
search(work[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: