您的位置:首页 > 其它

POJ 1703 Find them, Catch them 种类并查集

2014-02-25 16:55 405 查看
点击打开链接

Find them, Catch them

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27902 Accepted: 8514
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a]  

where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.

Source

POJ Monthly--2004.07.18

[b]在一个城市里面有两帮犯罪团伙,一共有n个犯罪的人,如果输入是D a b的话,代表a和b属于两个不同的犯罪团伙,A a b的话,让你判断a和b是否属于同一犯罪团伙还是无法判断。

种类并查集,讲得不错的一篇博客,推荐一下。点击打开链接
</pre><pre code_snippet_id="204289" snippet_file_name="blog_20140225_1_1619066" name="code" class="cpp">//1136K	704MS
#include<stdio.h>
#define M 100007
int pre[M],rank[M];
char s[1];
int n,m;
void init()
{
for(int i=1;i<=n;i++)
{pre[i]=i,rank[i]=0;}
}
int find(int x)
{
if(x==pre[x])return x;
int t=pre[x];
pre[x]=find(pre[x]);
rank[x]=(rank[x]+rank[t])%2;
return pre[x];
}
void unio(int a,int b)
{
int fa=find(a);
int fb=find(b);
pre[fa]=fb;
rank[fa]=(rank[a]+rank[b]+1)%2;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
init();
int a,b;
char c;
for(int i=1;i<=m;i++)
{
getchar();
scanf("%c",&c);
scanf("%d%d",&a,&b);
if(c=='D')unio(a,b);
else
{
if(find(a)==find(b))
{
if(rank[a]==rank[b])printf("In the same gang.\n");
else printf("In different gangs.\n");
}
else printf("Not sure yet.\n");
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: