您的位置:首页 > 其它

UVA 401 Palindromes 字符串

2014-02-24 23:27 477 查看


Palindromes

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is
read from left to right as when the string is read from right to left.

A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored
string because "A" and "I" are their own reverses, and "3" and "E" are each others' reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and
because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A", "T", "O", and "Y" are all their own reverses.

A list of all valid characters and their reverses is as follows.

CharacterReverseCharacterReverseCharacterReverse
AAMMYY
BNZ5
COO11
DP2S
E3Q3E
FR4
GS25Z
HHTT6
IIUU7
JLVV88
KWW9
LJXX
Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the
end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string
Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.
In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME
ISAPALINILAPASI
2A3MEAS
ATOYOTA


Sample Output

NOTAPALINDROME -- is not a palindrome.

ISAPALINILAPASI -- is a regular palindrome.

2A3MEAS -- is a mirrored string.

ATOYOTA -- is a mirrored palindrome.


Miguel Revilla 2001-04-16

好久没见到过这么恶心的水题了,要是OI模式也许会WA2-3组数据,可惜这个是ACM模式 TAT

要注意两点:
数字0 和 大写字母O 是等价的。 可以先把字符串备份一遍,再把0转换为O来处理
当字符串只有一个字符时,镜面对称的情况。

如果还有问题。。。去论坛看看吧:http://online-judge.uva.es/board/viewtopic.php?f=5&t=5863

#include <iostream>
using namespace std;

const string s1="123456789       ABCDEFGHIJKLMNOPQRSTUVWXYZ";
const string s2="1SE Z  8        A   3  HIL JM O   2TUVWXY5";
const string ss[4]={" -- is not a palindrome.\n\n",
" -- is a regular palindrome.\n\n",
" -- is a mirrored string.\n\n",
" -- is a mirrored palindrome.\n\n"};
string s,temp;
int i,b,b1,b2,len;
int main()
{
while (cin>>s){
b1=1; b2=2; b=1; temp=s;
len=s.size();
for (i=0;i<len;++i)
if (s[i]=='0') s[i]='O';
for (i=0;i<=len/2;++i){
if (s[i]!=s[len-i-1] && s1[s[i]-49]!=s2[s[len-i-1]-49]){
b=0; break;
}
if (b2 && s[i]==s[len-i-1] && s1[s[i]-49]!=s2[s[len-i-1]-49]) b2=0;
if (b1 && s1[s[i]-49]==s2[s[len-i-1]-49] && s[i]!=s[len-i-1]) b1=0;
}
if (len==1 && s2[s[0]-49]!=' ') b2=2;
if (!b) cout<<temp<<ss[b];
else cout<<temp<<ss[b1+b2];
}
return 0;
}


kdwycz的网站: http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: