您的位置:首页 > 其它

HDU 1150 Machine Schedule(最小点覆盖) 二分匹配

2014-02-24 21:50 330 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1150

Problem Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here
we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine
B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to
a suitable machine, please write a program to minimize the times of restarting machines.



Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i,
x, y.

The input will be terminated by a line containing a single zero.



Output

The output should be one integer per line, which means the minimal times of restarting machine.



Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0




Sample Output

3


/*

HDU 1150

题目大意;有两台机器A和B以及N个需要运行的任务。每台机器有M种不同的模式,而每个任务都恰好在一台机器上运行。如果它在机器A上运行,则机器A需要设置为模式xi,如果它在机器B上运行,则机器A需要设置为模式yi。每台机器上的任务可以按照任意顺序执行,但是每台机器每转换一次模式需要重启一次。请合理为每个任务安排一台机器并合理安排顺序,使得机器重启次数尽量少。

二分图的最小顶点覆盖数=最大匹配数

本题就是求最小顶点覆盖数的。

相当于是最小的点消灭掉所有的边,所以是最小顶点覆盖

*/

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

/* **************************************************************************
//二分图匹配(匈牙利算法的DFS实现)
//初始化:g[][]两边顶点的划分情况
//建立g[i][j]表示i->j的有向边就可以了,是左边向右边的匹配
//g没有边相连则初始化为0
//L是匹配左边的顶点数,R是匹配右边的顶点数
//调用:res=hungary();输出最大匹配数
//优点:适用于稠密图,DFS找增广路,实现简洁易于理解
//时间复杂度:O(VE)
//***************************************************************************/
//顶点编号从0开始的
#define MAXN 110
int LN,RN;//L,R数目
int g[MAXN][MAXN], linker[MAXN];
bool used[MAXN];
int dfs(int L)//从左边开始找增广路径
{
	int R;
	for(R = 0 ; R < RN ; R++ )//这个顶点编号从0开始,若要从1开始需要修改
	{
		if(g[L][R]!=0 && !used[R])
		{//找增广路,反向
			used[R]=true;
			if(linker[R] == -1 || dfs(linker[R]))
			{
				linker[R]=L;
				return 1;
			}
		}
	}
	return 0;//这个不要忘了,经常忘记这句
}
int hungary()
{
	int res = 0 ;
	int L;
	memset(linker,-1,sizeof(linker));
	for( L = 0 ; L < LN ; L++ )
	{
		memset(used,0,sizeof(used));
		if(dfs(L) != 0)
			res++;
	}
	return res;
}
int main()
{
	int k,i,j,res,L,R;
	while(~scanf("%d",&LN) && LN)
	{
		scanf("%d%d",&RN,&k);
		memset(g,0,sizeof(g));
		for(j = 0 ; j < k ; j++ )
		{
			scanf("%d%d%d",&i,&L,&R);
			if(L > 0 && R > 0)
				g[L][R] = 1;
		}
		res = hungary();
		printf("%d\n",res);
	}
	return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: