您的位置:首页 > 其它

10055 - Hashmat the Brave Warrior

2014-02-24 17:32 309 查看
Problem A
Hashmat the brave warrior

Input: standard input

Output: standard output

Hashmat is a brave warrior whowith his group of young soldiers moves from one place to another to fightagainst his opponents. Before fighting he just calculates onething, the difference between his soldier number and the opponent's soldiernumber. From this
difference he decides whether to fight or not. Hashmat'ssoldier number is never greater than his opponent.

Input

The input contains two integer numbers inevery line. These two numbers in each line denotes the number of soldiers inHashmat's army and his opponent's army or vice versa. The input numbers are notgreater than 2^32. Input is terminated by End of File.

Output

For each line of input,print the difference of number of soldiers between Hashmat's army and hisopponent's army. Each output should be in seperate line.

Sample Input:

10 12

10 14

100 200

[b]Sample Output:[/b]

2

4

100
#include<stdio.h>

int main(){
long a,b,difference;
while(scanf("%ld%ld",&a,&b)!=EOF)
{
difference=a-b;
if(difference<0)
{
difference*=-1;
}
printf("%ld\n",difference);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: