您的位置:首页 > 其它

[map]PAT1009 Product of Polynomials

2014-02-22 16:06 393 查看


1009. Product of Polynomials (25)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 3 3.6 2 6.0 1 1.6


题意:给出了两个多项式的系数和幂次数,求这两个多项式相乘后的系数和幂次数。

思路:直接模拟相乘就可以了,但是要注意一点就是,幂次数相同的需要合并,系数为0需要去掉。因此我选择用map

#include<iostream>
#include<iomanip>
#include<map>
#include<iterator>

using namespace std;

class Node
{
public:
int x;
double y;
};

map<int,double> node;

Node node1[110],node2[110];

int main()
{
int n,m;
int i,j,k;
cin>>n;
for(i=0;i<n;i++)
cin>>node1[i].x>>node1[i].y;
cin>>m;
for(i=0;i<m;i++)
cin>>node2[i].x>>node2[i].y;
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
int r=node1[i].x+node2[j].x;
double t=node1[i].y*node2[j].y;
if(node.count(r))
{
t=t+node[r];
if(t==0) node.erase(r);
else node[r]=t;
}
else
{
node.insert(make_pair(r,t));
}
}
}
cout<<node.size();
map<int,double>::reverse_iterator it;
for(it=node.rbegin();it!=node.rend();++it)
{
cout<<" "<<it->first<<" ";
cout<<fixed<<setprecision(1)<<it->second;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  map