您的位置:首页 > 编程语言 > C语言/C++

【c++】PAT (Advanced Level) A+B for Polynomials (25)

2014-02-22 11:50 357 查看



1002. A+B for Polynomials (25)

时间限制
400 ms

内存限制
32000 kB

代码长度限制
16000 B

判题程序
Standard

作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi
(i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2


1.变量又弄错了

2.没有注意到格式要求

cout<<fixed<<setprecision(2)<<cost;//<iomanip>


//Artemis
#include<iostream>
#include<iomanip>
using namespace std;

int main(){
double trouble[1001]={0};
int m1,m2;
cin>>m1;
while(m1--){
int nk;
double a;
cin>>nk;
cin>>a;
trouble[nk]=a;
}
cin>>m2;
while(m2--){
int nk;
double a;
cin>>nk>>a;
trouble[nk]=trouble[nk]+a;
}
int count=0;
for(int i=0;i<=1000;i++){
int nk,a;
if(trouble[i]!=0){
count++;
}
}
cout<<count;
for(int i=1000;i>=0;i--){
if(trouble[i]!=0){
cout<<" "<<i<<" "<<fixed<<setprecision(1)<<trouble[i];
}
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: