您的位置:首页 > 产品设计 > UI/UE

hdu 1711 Number Sequence

2014-02-21 23:57 337 查看
[align=left]Problem Description[/align]
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.

[align=left]Input[/align]
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

[align=left]Output[/align]
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

[align=left]Sample Input[/align]

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1


[align=left]Sample Output[/align]

6
-1


#include<cstdio>
#include<iostream>
using namespace std;
const int MAX=1000000+10;
int a[MAX];
int b[10000+10];
int next[10000+10];
void get_next(int *t,int len)
{
int i=0,j=-1;
next[0]=-1;
int Lt=len;
while(i<Lt)
{
if(j==-1||t[i]==t[j])
{
++i,++j;
next[i]=j;
}
else
j=next[j];
}
}
int KMP(int a[],int b[],int lena,int lenb)
{
int i=0,j=0;
while (i<lenb && j<lena)
{
if (j == -1 || a[j] == b[i])
{
++i;
++j;
}
else
j=next[j];

}
if (j == lena)
return i-j+1;
return -1;
}
int main()
{
int n,m,t;
cin>>t;
while (t--)
{
cin>>n>>m;
for (int i=0;i<n;++i)
scanf("%d",&a[i]);
for (int i=0;i<m;++i)
scanf("%d",&b[i]);
get_next(b,m);
cout<<KMP(b,a,m,n)<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: