您的位置:首页 > 其它

1053. Path of Equal Weight (30)

2014-02-21 20:52 260 查看
Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The
weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the
lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.



Figure 1
Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number.
The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end
of the line.

Note: sequence {A1, A2, ..., An} is said to be
greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai
= Bi for i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

思路:很具代表性的一道图的遍历的题目,用DFS和邻接链表的数据结构,基本没有什么坑点,但是题目要读仔细,特别是加粗的那几个字

AC参考代码:

#include <iostream>
#include <vector>
#include <fstream>
#include <algorithm>
using namespace std;

int N,M,S;
vector<int> node;
vector<vector<int> > edge(101);//edge中储存的是索引 索引再根据node找到对应的值
vector<vector<int> >result;//把符合条件的路径节点作为vector数组储存起来
vector<int> isVisited(101);//标记节点是否被遍历
vector<int> currentNode;//储存当前路径上的节点
int sum = 0;//路径权重和

int compare(vector<int> a,vector<int> b){//按照字典逆序排序
int minN = a.size()<b.size()?a.size():b.size();
for(int i=0;i<minN;i++){
if(a[i]!=b[i]){
return a[i]>b[i];
}
}
return 0;
}
void DFS(int i){    //遍历并寻找满足条件的路径并记录节点
isVisited[i] = 1;
currentNode.push_back(node[i]);
sum += node[i];
if(edge[i].size()==0){//到达叶子节点
if(sum==S){ //这条路径符合要求
result.push_back(currentNode);
}
}else{
for(int j=0;j<edge[i].size();j++){
DFS(edge[i][j]);
}
}
sum -= node[i];     //遍历完叶子节点后返回需要修改当前路径节点和节点和
currentNode.pop_back();
}
int main()
{
//ifstream cin("1.txt");
cin>>N>>M>>S;
node.resize(N);
for(int i=0;i<N;i++){
cin>>node[i];
}
for(int i=0;i<M;i++){
int index,arrSize;
cin>>index>>arrSize;
for(int j=0;j<arrSize;j++){
int temp;
cin>>temp;
edge[index].push_back(temp);
}
}
DFS(0);
sort(result.begin(),result.end(),compare);//按字典逆序排序
for(int i=0;i<result.size();i++){
for(int j=0;j<result[i].size();j++){
j<result[i].size()-1?cout<<result[i][j]<<" ":cout<<result[i][j]<<endl;
}
}
return 0;
}


编译器

Assembler (nasm)
Basic (blassic) C (gcc)
C# (gmcs) C++ (g++)
Go (gccgo) Haskell (ghc) Java (java)
Lisp (clisp) Lua (lua)
Pascal (fpc) Perl (perl)
PHP (php) Plaintext (cat)
Python (python3) Python (python2)
Ruby (ruby) Scheme (guile)
Shell (bash) Vala (valac)
VisualBasic (vbnc)

使用高级编辑
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: