您的位置:首页 > 其它

hdu2602 Bone Collector(01背包)

2014-02-21 09:18 405 查看


Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 24223    Accepted Submission(s): 9818


Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



 

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output

14

 
就是标准的01背包模板

#include<stdio.h>
#include<string.h>
int p[1004],v[1004],f[1004];
int main()
{
int t,n,V,i,j;
scanf("%d",&t);
while(t--)
{
memset(f,0,sizeof(f));
scanf("%d%d",&n,&V);
for(i=0; i<n; i++)
scanf("%d",&p[i]);
for(i=0; i<n; i++)
scanf("%d",&v[i]);
for(i=0; i<n; i++)
for(j=V; j>=v[i]; j--)
{
int temp=f[j-v[i]]+p[i];
if(temp>f[j])
f[j]=temp;
}
printf("%d\n",f[V]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: