您的位置:首页 > 产品设计 > UI/UE

九度OJ 1442 A sequence of numbers

2014-02-19 09:16 363 查看
题目地址:http://ac.jobdu.com/problem.php?pid=1442

题目描述:
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants
to know some numbers in these sequences, and he needs your help.

输入:
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating
that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.

输出:
Output one line for each test case, that is, the K-th number module (%) 200907.

样例输入:
2
1 2 3 5
1 2 4 5


样例输出:
5
16


#include <stdio.h>

#define M 200907

long long fun1(long long data[], int k){
long long p = data[1] - data[0];
return ((data[0] % M) + (((k-1) % M) * (p % M)) % M) % M;
}

long long fun2(long long data[], int k){
long long p = data[1] / data[0];
long long ans = data[0];
--k;
while (k != 0){
if (k % 2 == 1){
ans = (ans * p) % M;
}
k /= 2;
p = (p * p) % M;
}
return ans;
}

long long KthNumber(long long data[], int k){
int flag;

if ((data[1] - data[0]) == (data[2] - data[1]))
flag = 0;
else
flag = 1;
if (flag == 0){
return fun1(data, k);
}
else{
return fun2(data, k);
}
}

int main(void){
int n;
long long data[3];
int k;
int i;

while (scanf ("%d", &n) != EOF){
while (n-- != 0){
for (i=0; i<3; ++i){
scanf ("%lld", &data[i]);
}
scanf ("%d", &k);
printf ("%d\n", KthNumber (data, k));
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: