您的位置:首页 > 其它

一道贪心的题,我想知道这种方法为什么不对。。。

2014-02-18 17:15 183 查看
题目:

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each
of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the
same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50


Sample Output

10
20
30


我的思路就是找出所有可以一起运的,然后在剩下的里面找可以同时运的,依此类推。同时运的组数就是最少需要时间的十分之一。

代码如下:

#include<cstdio>
#include<algorithm>
using namespace std;
struct node {
int a;
int b;
};
bool cmp(struct node a,struct node b)
{
return a.a<b.a;
}

main()
{
struct node shi[220],hu;
int sum;
int t=0;
int x,y;
int i,j;
int n;
scanf("%d",&t);
for(;t>0;t--)
{
sum=0;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&shi[i].a,&shi[i].b);
if(shi[i].a>shi[i].b)
{
hu.a=shi[i].a;
shi[i].a=shi[i].b;
shi[i].b=hu.a;
}
}
sort(shi,shi+n,cmp);
while(n)
{
x=shi[0].a;
y=shi[0].b;
for(j=0;j<n-1;j++)
{
shi[j]=shi[j+1];
}
n--;
for(i=0;i<n;i++)
{
if(y<=shi[i].a)
{
x=shi[i].a;
y=shi[i].b;
for(j=i;j<n-1;j++)
{
shi[j]=shi[j+1];
}
n--;
i--;
}
}
sum++;
}
sum=sum*10;
printf("%d\n",sum);

}
}


但是这个代码老是WA。。。

求大神指点哪里有问题。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐