您的位置:首页 > 理论基础 > 数据结构算法

数据结构之KMP算法---hdu---Number Sequence

2014-02-17 11:10 465 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1711

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.

[align=left]Input[/align]
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

[align=left]Output[/align]
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

[align=left]Sample Input[/align]

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1


[align=left]Sample Output[/align]

6
-1
代码实现:
[code]#include <iostream>
#include <cstring>
using namespace std;
int next[10005];
int a[1000005],b[10005];
void getNext(int *b,int m,int n)
{
int i=0,j=-1;
next[0]=-1;
while(i<n)
{
if(j==-1||b[i]==b[j])
{
i++;j++;next[i]=j;
}
else
{
j=next[j];
}
}
}
int main()
{
int t,m,n;
cin>>t;
while(t--)
{
cin>>m>>n;
for(int i=0;i<m;i++)
{
cin>>a[i];
}
for(int j=0;j<n;j++)
{
cin>>b[j];
}
getNext(b,m,n);

int i=0,j=0,flag=0;
while(i<m)
{
if(j==-1||a[i]==b[j])
{
i++;j++;
}
else
{
j=next[j];
}
if(j==n)
{
flag++;
cout<<i-n+1<<endl;
break;
}
}
if(flag==0)cout<<"-1"<<endl;
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: