您的位置:首页 > 其它

Ningbo [1217] Dinner(简单题,但是注意输出,pe3遍)

2014-02-15 10:20 393 查看
1、http://cdn.ac.nbutoj.com/Problem/view.xhtml?id=1217

注意输出,中间有空格,最后没有,处理空格错了3遍

2、题目:

[1217] Dinner

时间限制: 1000 ms 内存限制: 32768 K
问题描述

Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take
backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With
these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.

输入

There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.

输出

For each test of the input, output all the name of tableware.

样例输入

3 basketball fork chopsticks
2 bowl letter


样例输出

fork chopsticks
bowl


提示

The tableware only contains: bowl, knife, fork and chopsticks.


来源

辽宁省赛2010


3、AC代码:

#include<stdio.h>
#include<math.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1005
char s[105];
int main()
{
int n;

while(scanf("%d",&n)!=EOF)
{
int flag=0;
for(int i=1; i<=n; i++)
{
scanf("%s",s);
if(flag==0)
{
if(strcmp(s,"bowl")==0)
printf("%s",s),flag=1;
else if(strcmp(s,"knife")==0)
printf("%s",s),flag=1;
else if(strcmp(s,"fork")==0)
printf("%s",s),flag=1;
else if(strcmp(s,"chopsticks")==0)
printf("%s",s),flag=1;
}
else
{
if(strcmp(s,"bowl")==0)
printf(" %s",s);
else if(strcmp(s,"knife")==0)
printf(" %s",s);
else if(strcmp(s,"fork")==0)
printf(" %s",s);
else if(strcmp(s,"chopsticks")==0)
printf(" %s",s);
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐