您的位置:首页 > 其它

1065. A+B and C (64bit) (20)

2014-02-14 16:18 381 查看
Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:
Case #1: false
Case #2: true
Case #3: false


思路:根据是否溢出来做 ,但是好郁闷 arr[i].a+arr[i].b作为整体时就出错! long long total = arr[i].a+arr[i].b; 用total代替就OK' 真心搞不懂啊!!

AC代码:

#include <iostream>
using namespace std;
int N;
struct Node{
long long a;
long long b;
long long c;
};
Node arr[11];
int main()
{
cin>>N;
for(int i=0;i<N;i++){
cin>>arr[i].a>>arr[i].b>>arr[i].c;
long long total = arr[i].a+arr[i].b;
if(arr[i].a<0 && arr[i].b<0 && total>=0){   //发生溢出
cout<<"Case #"<<i+1<<": "<<"false"<<endl;
}else if(arr[i].a>0 && arr[i].b>0 && total<=0){
cout<<"Case #"<<i+1<<": "<<"true"<<endl;
}else{
if(total>arr[i].c){
cout<<"Case #"<<i+1<<": "<<"true"<<endl;
}else{
cout<<"Case #"<<i+1<<": "<<"false"<<endl;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: