您的位置:首页 > 其它

山理和山建大一新生友谊赛 D - We Love MOE Girls

2014-02-13 20:51 387 查看
D - We Love MOE Girls
Time Limit:500MS Memory Limit:32768KB 64bit IO Format:%I64d
& %I64u
Submit Status

Description

Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them.

In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu".

There are two situations:

If a sentence ends with "desu", she changes "desu" into "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence.

Given an original sentence, what will it sound like aften spoken by Nanako?

Input

The first line has a number T (T <= 1000) , indicating the number of test cases.

For each test case, the only line contains a string s, which is the original sentence.

The length of sentence s will not exceed 100, and the sentence contains lowercase letters from a to z only.

Output

For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output which Nanako will say.

Sample Input

2
ohayougozaimasu
daijyoubudesu


Sample Output

Case #1: ohayougozaimasunanodesu
Case #2: daijyoubunanodesu


#include <stdio.h>
#include <string.h>

int main()
{
char a[120];
int n, t = 0;
int i;
scanf("%d", &n);
while(n--)
{
scanf("%s", a);
printf("Case #%d: ", ++t);
int len = strlen(a);
if(a[len-1] == 'u' && a[len-2] == 's' && a[len-3] == 'e' && a[len-4] == 'd' &&
a[len-5] == 'o' && a[len-6] == 'n' && a[len-7] == 'a' && a[len-8] == 'n')
{
printf("%s", a);
}
else if(a[len-1] == 'u' && a[len-2] == 's' && a[len-3] == 'e' && a[len-4] == 'd')
{
for(i=0; i<len-4; i++)
{
printf("%c", a[i]);
}
printf("nanodesu\n");
}
else {
printf("%s", a);
printf("nanodesu\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: