您的位置:首页 > 编程语言 > C语言/C++

Pat(Advanced Level)Practice--1013(Battle Over Cities)

2014-02-13 13:05 363 查看

Pat1013代码

题目描述:

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities
connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is
occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow,
each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input
3 2 3
1 2
1 3
1 2 3

Sample Output
1
0
0


题目其实就是求出联通子集的个数,然后需要几条边将其连接起来,由图论知识知道N个顶点至少需要N-1条边连接成联通图,所以本题DFS或者BFS搜索一遍即可。。。
AC代码:
一:DFS解题
#include<cstdio>
#include<cstring>
#define MAX 1001

using namespace std;

int map[MAX][MAX];
int visited[MAX];

void Init()
{
int i,j;
for(i=0;i<MAX;i++)
for(j=0;j<MAX;j++)
map[i][j]=0;
}

void DFS(int n,int k)
{
int i;
visited[k]=1;
for(i=1;i<=n;i++)
if(map[i][k]==1&&!visited[i])
DFS(n,i);
}

int main(int argc,char *argv[])
{
int N,M,K;
int i,j,k;
int ans;
Init();
scanf("%d%d%d",&N,&M,&K);
for(k=0;k<M;k++)
{
scanf("%d%d",&i,&j);
map[i][j]=1;
map[j][i]=1;
}
while(K--)
{
scanf("%d",&k);
memset(visited,0,sizeof(visited));
ans=0;
visited[k]=1;
for(i=1;i<=N;i++)
{
if(!visited[i])
{
DFS(N,i);
ans++;
}
}
printf("%d\n",ans-1);
}

return 0;
}


二:BFS解题
#include<cstdio>
#include<cstring>
#include<deque>
#define MAX 1001

using namespace std;

int visited[MAX];
int map[MAX][MAX];

void Init()
{
int i,j;
for(i=0;i<MAX;i++)
for(j=0;j<MAX;j++)
map[i][j]=0;
}

int main(int argc,char *argv[])
{
int i,j,k;
int N,M,K;
int ans;
Init();
scanf("%d%d%d",&N,&M,&K);
for(k=1;k<=M;k++)
{
scanf("%d%d",&i,&j);
map[i][j]=1;
map[j][i]=1;
}
while(K--)
{
scanf("%d",&k);
memset(visited,0,sizeof(visited));
visited[k]=1;
ans=0;
for(i=1;i<=N;i++)
{
if(!visited[i])
{
deque<int> q;
visited[i]=1;
ans++;
q.push_back(i);
while(!q.empty())
{
k=q.front();
q.pop_front();
for(j=1;j<=N;j++)
{
if(!visited[j]&&map[j][k]==1)
{
visited[j]=1;
q.push_back(j);
}
}
}
}
}
printf("%d\n",ans-1);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Advance Pat C++ STL BFS DFS